Issues Saving Settings in PGM, POSWeb & Client Portal

Minor incident AU data center Client Portal PGM PosWeb
2025-10-30 14:41 CET · 4 days, 21 hours, 19 minutes

Updates

Update

We’ve now resolved the incident.

November 4, 2025 · 14:53 CET
Update

We’ve identified an issue that may prevent settings from being saved correctly in Perfect Gym Manager (PGM), POSWeb & Client Portal.

Our Infrastructure team is currently working on a fix to restore full functionality.

Updates will be shared here as soon as progress is made.

October 30, 2025 · 14:47 CET

← Back