Perfect Gym services are temporalily down

Major incident EU data center NA data center API Client Portal Mobile App PGM PosWeb API Client Portal Mobile App PGM PosWeb
2025-10-21 12:45 CEST · 2 hours, 58 minutes

Updates

Update

After a period of monitoring, we are able to confirm that the issue was fully resolved, and it will not occur again. Thank you for your patience.

October 21, 2025 · 15:43 CEST
Issue

We are doing everything we can to get back online as soon as possible. Updates will follow.

October 21, 2025 · 12:45 CEST

← Back