Interruptions to PG services due to Azure network infrastructure issues

Major incident EU data center AU data center SG data center NA data center API Client Portal Mobile App PGM PosWeb Reports Payment Processing API Client Portal Mobile App PGM PosWeb Reports Payment Processing API Client Portal Mobile App PGM PosWeb Reports Payment Processing API Client Portal Mobile App PGM PosWeb Reports Payment Processing
2025-10-09 08:30 CEST · 3 hours, 25 minutes

Updates

Resolved

All Azure issues were reported as resolved by Microsoft on their status page https://azure.status.microsoft/status, and therefore, after a period of due diligence and observation of our own systems, as of 08:30 UTC, we restored our systems to normal capacity, and we have not observed any impact directly caused by this issue since then.

October 10, 2025 · 12:42 CEST
Issue

We were experiencing intermittent outages of Perfect Gym applications, first reported this morning at around 10:00 CEST. The issues on uptime of Perfect Gym applications that were experienced were intermittent and non-deterministic, meaning that it was affecting some of our clients some of the time. The root cause of this is in problems being experienced by a third-party provider. Azure Front Door (AFD) is experiencing an ongoing global issue, however, based on the updates from Microsoft, the majority of the issues have been mitigated, and they are continuing efforts to recover all systems. You can follow the status of the Azure incident here: https://azure.status.microsoft/status

October 9, 2025 · 15:40 CEST

← Back