We are currently experiencing a critical issue affecting all applications

Major incident EU data center NA data center API Client Portal Mobile App PGM PosWeb Reports Payment Processing API Client Portal Mobile App PGM PosWeb Reports Payment Processing
2025-09-26 10:06 CEST · 20 minutes

Updates

Resolved

We’ve now resolved the incident. Thanks for your patience.

September 26, 2025 · 15:44 CEST
Issue

Our engineers are working at maximum capacity to fix this a soon as possible.

September 26, 2025 · 10:06 CEST

← Back