We are investigating an issue with PGM

Major incident AU data center PGM
2026-01-13 05:53 CET · 11 minutes

Updates

Resolved

Issue resolved.

January 13, 2026 · 06:04 CET
Investigating

We have detected issues and we are currently investigating, we’ll update you soon.

January 13, 2026 · 05:53 CET

← Back