Temporary web application unavailability

Major incident EU data center NA data center API Client Portal Mobile App PGM PosWeb Reports Payment Processing API Client Portal Mobile App PGM PosWeb Reports Payment Processing
2026-02-03 17:00 CET · 1 hour, 10 minutes

Updates

Resolved

After a period of post-incident monitoring and waiting to check that all systems are recovering correctly, we are now closing the incident.

We are still investigating the cause of this, but the early indication is that it is similar to the incident that previously occurred on 20th January. Assuming that is correct, the root cause fix for this is in the latter stage of development and QA now, and we plan to deploy that as soon as possible.

February 3, 2026 · 18:55 CET
Monitoring

The main issue was resolved as of 18:28 CET.
We are continuing to monitor API performance.

February 3, 2026 · 18:39 CET
Monitoring

Our engineers have been able to resolve the issue, and systems are now recovering. We are monitoring closely.

February 3, 2026 · 18:28 CET
Update

Issues are persisting, but our engineers are doing everything they can to get everything back up and running. This is impacting our European and North American DataCenters.

February 3, 2026 · 18:22 CET
Investigating

We are currently investigating instability and performance issues.

February 3, 2026 · 18:05 CET

← Back