WorldPay - Issue adding new credit cards

Minor incident AU data center Payment Processing
2026-03-16 02:14 CET · 2 hours, 36 minutes

Updates

Resolved

The issue affecting the ability to add new credit cards via Worldpay has now been resolved.

Worldpay has confirmed the disruption which temporarily impacted the Secure Card Vault service. Their team has identified the issue and implemented a fix.

We are continuing to monitor the service, and adding new credit cards should now function as expected.

March 16, 2026 · 04:49 CET
Investigating

We are currently investigating reports of users being unable to add new credit cards when using WorldPay as the payment gateway.

At this stage the issue cannot be reproduced on our side. We have contacted WorldPay to investigate a potential service disruption and are awaiting further information from their team.

Existing payment methods and transactions are not impacted.

We will provide further updates as soon as more information becomes available.

March 16, 2026 · 02:14 CET

← Back