Mobile App Booking & Login Issues

Major incident EU data center AU data center SG data center NA data center Mobile App Mobile App Mobile App Mobile App UK data center Mobile App
2026-03-26 23:58 CET · 7 hours, 30 minutes

Updates

Resolved

The issue has now been resolved. Class bookings have been restored and users are once again able to log in to the app successfully.

Thank you for your patience while we worked through this.

Root Cause Analysis
On March 27, 2026, customers experienced issues with logging in to the mobile app and making class bookings.

Our investigation found this was caused by an overload on the database environment, which resulted in degraded performance across the affected mobile app services. This prevented some users from logging in successfully and also impacted class booking functionality.

Once identified, the issue was escalated to our Infrastructure team , who worked to reduce the load and restore normal service. Following this, class bookings were restored and users were again able to log in to the app successfully.

The issue is now resolved.

To help reduce the likelihood of this occurring again, the internal teams are reviewing the events that led to the database overload and any related monitoring or safeguards that can be improved.

March 27, 2026 · 07:27 CET
Investigating

We are continuing to investigate the issue affecting mobile app login and bookings. Our teams are actively reviewing the related services and we will provide a further update as soon as more information is available.

March 27, 2026 · 05:32 CET
Issue

We have detected issues with the mobile app and we are currently investigating, we’ll update you ASAP.

March 26, 2026 · 23:58 CET

← Back