Problems with the POS application

Major incident EU data center PosWeb
2026-04-08 08:19 CEST · 36 minutes

Updates

Resolved

The issue has been resolved.

April 8, 2026 · 08:55 CEST
Issue

We are currently experiencing issues with the POS app. A ‘Server Error’ appears when attempting any action. Our team is working on resolving the issue.

April 8, 2026 · 08:19 CEST

← Back