Upcoming Maintenance from 2026-05-01 17:00 CEST to 2026-05-01 18:00 CEST

Scheduled maintenance AU data center SG data center API Client Portal Mobile App PGM PosWeb Reports Payment Processing API Client Portal Mobile App PGM PosWeb Reports Payment Processing
2026-05-01 17:00 CEST · 1 hour

Updates

Update

All operations have been completed and systems are back online. Thank you for your patience here.

May 1, 2026 · 18:28 CEST
Monitoring

Some operations are taking longer than expected. We are working on bringing the remainder of systems online. Thank you for your patience

May 1, 2026 · 18:13 CEST
Resolved

This maintenance has been concluded as planned.

May 1, 2026 · 18:00 CEST
Started

This maintenance is now starting as planned.

May 1, 2026 · 17:00 CEST
Scheduled

This is a scheduled maintenance aimed at improving system stability and overall performance. All services will be intermittently unavailable during the window. Thank you for your patience as we complete these works.

April 24, 2026 · 09:16 CEST

← Back