Mobile App Instability

Minor incident AU data center SG data center Mobile App Mobile App
2026-08-12 02:21 CEST · 23 hours, 51 minutes

Updates

Resolved

We found the root cause of the mobile app login and error issue and have rolled out a fix. Users should no longer experience login failures or unexpected errors in the PerfectGym mobile app.

As noted earlier, any bookings made during the incident completed successfully despite the errors shown.

Thanks for your patience while we worked through this.

August 13, 2026 · 02:11 CEST
Issue

We’re aware of an issue affecting some users of the PerfectGym mobile app. Users may be unable to login or encounter unexpected errors.

Bookings made through the mobile app may still successfully complete even if an error is displayed.

The mobile team is aware of the issue and is working on a solution. We appreciate your patience while we work through this.

August 12, 2026 · 02:21 CEST

← Back